[TRNSYS-users] type 9 problem

Stefan de Kool s.dekool at chri.nl
Wed May 31 23:23:12 PDT 2006

HI Constanze,


Concerning the first question, I think the problem is that trnsys only
accepts timesteps which have a value of 2^n, in which n is an integer (pos.
or neg.) value. You could try 2^-4 (0.0625). 


Attached you find an example of type 9. Put it in My documents together with
the scheme.txt. I hope it's useful


Good luck




Van: trnsys-users-bounces at engr.wisc.edu
[mailto:trnsys-users-bounces at engr.wisc.edu] Namens Constanze.Bongs at csiro.au
Verzonden: donderdag 1 juni 2006 7:48
Aan: trnsys-users at engr.wisc.edu
Onderwerp: [TRNSYS-users] type 9 problem




I am new to using TRNSYS and have run across the following problem which I
could not resolve using the manual or the mailing list archives. It is
probably really easy but I would be very happy if someone could give me a
"helping hand".


I want TRNSYS to read data (temperatures and relative humidity) from an
excel file and use that data as input to a building model. The data in the
sheet is taken at time steps of  5 minutes. I tried using TYPE 9 to read it.
However, when I try running the simulation (or Type 9 separately) I get the
following error messages:

1.) The system does not seem to allow me to input data time steps of less
than 1 hour into parameter 4 (time interval of data) - although it should if
I am well informed. I tried to use hrs as unit and filled in 1/12 or 0,0833
but still the same problem occurred. If I set it back at 1 hr it does not
give me the error message any more, but that does not make sense with the
data I want to use.

2.) Using 1 hr (to see if the type works) I get the error message that the
system is not able to read the file correctly. I inserted the path to the
file under external files (and under files in the window that opens as I
click on information). I checked the deck file and it gives me the right
path to the excel sheet. I also checked the excel sheet but can find no
error in the sheet. However, I cannot get TRNSYS to run the simulation (type
9) and read the file. 


Well, hope someone can help.








Constanze Bongs

CSIRO Division of Energy Technology


 <mailto:Constanze.Bongs at csiro.au> Constanze.Bongs at csiro.au

Ph: 02 4960 6104

fax: 02 4960 6111



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.onebuilding.org/pipermail/trnsys-users-onebuilding.org/attachments/20060601/40efb296/attachment-0001.htm>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: scheme.txt
URL: <http://lists.onebuilding.org/pipermail/trnsys-users-onebuilding.org/attachments/20060601/40efb296/attachment-0001.txt>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: type 9 example.TPF
Type: application/octet-stream
Size: 58385 bytes
Desc: not available
URL: <http://lists.onebuilding.org/pipermail/trnsys-users-onebuilding.org/attachments/20060601/40efb296/attachment-0001.obj>

More information about the TRNSYS-users mailing list