[TRNSYS-users] No single-threaded DLL option

Baboo Gowreesunker Baboo.Gowreesunker at brunel.ac.uk
Wed Mar 13 06:28:09 PDT 2013


It works, but I suggest you use the ivf10.1.zip template obtained from:


It's much easier, as you have relatively less set-up to do.


-----Original Message-----
From: mc05106 [mailto:mc05106 at mail.ntua.gr] 
Sent: 12 March 2013 20:25
To: trnsys-users at cae.wisc.edu
Subject: [TRNSYS-users] No single-threaded DLL option

 Hi to all,

 I was trying to modify a little Type 29 so that it will display output  withdecimals.

 My university has TRNSYS 16.1 installed in Win 7 machines. I tried to  compile type 29 from source code provided with Visual Studio 2005 and  Intel Fortran Compiler 10.1 and 11 but i kept getting the known symptom  where the produced DLL creates files "fort.xxx" where xxx is the logical  unit number.

 I read that the issue is the option in "Project settings" > Fortran >  Libraries > "Use run-time Libraries" must be "Single-Threaded DLL" but  in my Visual Studio 2005 there was no such option!(only options where  all "Multi-Threaded").

 I finally solved with compiling in an (Q)EMUlated windows xp machine  with CVF 6.6b.

 I would like to ask is it possible to compile in windows 7 enviroment?

 Which is the recommended compiler for TRNSYS 16.1 in Windows 7? are  there any alternatives?

 Thank you in advance,
 AXAOPOULOS IOANNIS, Undergraduate Student  School of Mechanical Engineering  National Technical University of Athens

More information about the TRNSYS-users mailing list