[TRNSYS-users] Type169 could not be loaded (Python direct call)

Mts Mcs mtsmcs at protonmail.com
Thu Apr 8 08:11:00 PDT 2021

Hello, I'm experiencing the dreaded "Type169 could not be located in either the trndll.dll or in an external dll." error message. There are several threads about this issue, including a very recent one. I've visited every one of them, however none of the suggestions have solved the issue.

Here's some information:
*Trnsys install location C:\TRNSYS18 (32 bit version)
*Python install location C:\Python
*The user is listed as administrator in netplwiz

What I've tried:
* Python 3.9 32bit
* Python 3.6 32bit
* Python 3.6 64bit
* Python 3.8.3 32bit w/ Type169 built for Python 3.8 (Yuichi's version -
* Unzipping embedded Python files to Exe directory (a method from Yuichi's site)
* Windows PATH seems to be right (I can launch Python from cmd.exe, as well as the path is listed in the settings)
* Countless restarts
* Running TRNSYS as administrator from right click menu

Is there anything else I could do?

Best regards
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.onebuilding.org/pipermail/trnsys-users-onebuilding.org/attachments/20210408/7bcdb6c9/attachment.html>

More information about the TRNSYS-users mailing list