[TRNSYS-users] Problem with DLL on several computers

Tobias Henzler tobias.henzler at ige.uni-stuttgart.de
Thu Jan 9 02:41:26 PST 2014

Hi David,


thank you very much for your answer. I did several more test simulations on different PCs.

The error message that I mentioned occurred due to strange simulation results on some PCs but is located at a forcing function (Type 14). You are right, if I turn the debug mode flag off, the simulation will finish (this flag was equally  "on" at each PC) but of course the strange results persist. 

I checked the content of the release folder, but the content was also the same on each PC.


The problem that I realized is that the simulation only works if I run the simulation as network administrator, if I do that as a local PC administrator the problems will occur. 

I have never had such a problem concerning user permissions and it always worked well with local PC administration permissions (for reading, writing and installation).


Have you ever heard about it? I am really not sure if it is a problem in our network or if it is a windows permission problem.


Kind regards



Dipl.-Ing. Tobias Henzler


University of Stuttgart

Institut für Gebäudeenergetik (IGE)

Pfaffenwaldring 35

70569 Stuttgart


Mailto: tobias.henzler at ige.uni-stuttgart.de

Von: David BRADLEY [mailto:d.bradley at tess-inc.com] 
Gesendet: Mittwoch, 8. Januar 2014 23:09
An: TRNSYS users mailing list at the Solar Energy Lab, UW-Madison;  <mailto:tobias.henzler at ige.uni-stuttgart.de> tobias.henzler at ige.uni-stuttgart.de
Betreff: Re: [TRNSYS-users] Problem with DLL on several computers


  I would be very surprised if this error had anything to do with the operating system. In a Trnsys16 component, you had to reserve the number of outputs that you wanted your Type to use and you did so by a command that looked something like:

INFO(6) = 12

if you wanted to reserve 12 outputs. The error you are getting is that some component is reserving a certain number of outputs for itself and then is setting an output that is outside of the reserved range. The following would cause the error:

INFO(6) = 12
OUT(14) = someVariable

The error message should mention the Unit and Type number of the component that is causing the problem. Please send me that information and I may be able to help you look a bit further.

I have two guesses as to why the error occurs on some computers but not on others. First, the check that is generating the error can be turned off by changing the "debug mode" flag in the simulation control cards. In the Studio, open the control cards tool (where you set the simulation start and stop times) and scroll down to the field that says "debug mode" Debug mode may be turned off on one computer but not the other. Second (more likely) there is another DLL in the ..\TrnsysXX\UserLib\DebugDLLs\ or ..\TrnsysXX\UserLib\ReleaseDLLs\ directory of one of the computers but not the other. 
Kind regards,

On 1/8/2014 09:10, Tobias Henzler wrote:

Dear TRNSYS-Users,


I am currently working on several type programming projects with FORTRAN in CVF. It usually works fine and there is no problem in using it with different versions (TRNSYS 16_1, 17_0) and on several PCs.

Now a strange error occurred with one type as it does not work equally on different PCs. The DLL is of course the same, and the configurations are also equal.

In that special case, it works on XP-Mode properly meanwhile on Win7 the results differ extremely and an error occurs (TRNSYS Message 427). The problem exists on some PCs with Win7, but works on others with Win7:


  "An OUTPUT from the specified component model has been written to the 

global OUT array in a location beyond the allocated number of outputs 

from this model. Please check the component carefully to insure that 

INFO(6) is set correctly. The simulation has been aborted to avoid 

problems caused by over-writing the outputs from other component models"


I do not think that it is a problem of WinXP/Win7. In my opinion it might also be a problem with missing components that are supposed to be located in the system folder.

Has anyone ever had a problem with a DLL not working equally on different PCs?


Best regards and thanks in advance



University of Stuttgart

mailto: Tobias.henzler at ige.uni-stuttgart.de

TRNSYS-users mailing list
 <mailto:TRNSYS-users at cae.wisc.edu> TRNSYS-users at cae.wisc.edu
 <https://mailman.cae.wisc.edu/listinfo/trnsys-users> https://mailman.cae.wisc.edu/listinfo/trnsys-users

Thermal Energy Systems Specialists, LLC
22 North Carroll Street - suite 370
Madison, WI  53703 USA
 <mailto:d.bradley at tess-inc.com> d.bradley at tess-inc.com
 <http://www.tess-inc.com> http://www.tess-inc.com
 <http://www.trnsys.com> http://www.trnsys.com

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.onebuilding.org/pipermail/trnsys-users-onebuilding.org/attachments/20140109/7ccc0551/attachment-0001.htm>

More information about the TRNSYS-users mailing list