AW: [TRNSYS-users] Type 4, wrong parameter definition?

Timo Sengewald timo.sengewald at
Fri Jan 20 07:30:06 PST 2006

The reason for the error message was a data reader (Type 9) which had to
read hourly data, although the data interval (parameter 4) was set to 6
minutes. But I have got no idea, why the error message was generated for the
storage tank...


-----Ursprüngliche Nachricht-----
Von: trnsys-users-bounces at
[mailto:trnsys-users-bounces at] Im Auftrag von Timo Sengewald
Gesendet: Freitag, 20. Januar 2006 15:22
An: trnsys-users at
Cc: ausgang at
Betreff: [TRNSYS-users] Type 4, wrong parameter definition?

Hello out there,

I am currently occupied by simulating a medium scale solar DHW system. In a
first step I use two strorage tanks: one solar storage tank (Type 4, mode 2
--> variable inlets, 10 nodes, 2 heating elements) and a hot water 
--> storage
tank (Type 4 Mode 3 --> user defined inlets)

The error message I get is caused by the solar storage tank: 31 parameters
are required and 29 were specified. I looked up the parameter definition in
the manual and I think the number of parameters (29) the proforma provides
is correct. So I tried a debug run with CVF. When this tank is called the
first time, NP for the call of TYPECK really is 31 and the error message is

It is weird that with the same two tanks modelled in any other project, all
works fine.

I tried many parameter combinations and I changed the component order ... I
am just becoming desperate. I have used TRNSYS for several years now and it
is some time ago I got stucked as badly as this time.

Could somebody help me? What may be the reason for this strange behavior?

Best regards


Timo Sengewald

BLS Energieplan GmbH
Elsenstraße 106
D-12435 Berlin
Tel.: +49 30 53 32 81-0
Fax: +49 30 53 32 81-40

TRNSYS-users mailing list
TRNSYS-users at

More information about the TRNSYS-users mailing list