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Introduction  

TRNSYS 17 Background  
TRNSYS is a complete, modular, and expansible simulation environment for the transient 
simulation of thermal systems including multi-zone buildings. It is used by engineers and 
researchers around the world to validate new energy concepts, from simple solar domestic 
hot water systems to the design and simulation of buildings and their equipment, including 
control strategies, occupant behavior, alternative energy systems (wind, solar, photovoltaic, 
hydrogen systems), etc.  

One of the key factors in TRNSYS’ success over the last 25 years is its open, modular 
structure. The source code of the kernel as well as the component models is delivered to the 
users. This simplifies extending existing models to make them fit the user’s specific needs.  

The DLL-based architecture allows users and third-party developers to easily add custom 
component models, using all common programming languages (C, C++, PASCAL, 
FORTRAN, etc.). In addition, TRNSYS can be easily connected to many other applications, 
for pre- or post-processing or through interactive calls during the simulation (e.g. Microsoft 
Excel, Matlab, COMIS, etc.). TRNSYS applications include: 

• Solar systems (solar thermal and PV) 
• Low energy buildings and HVAC systems with advanced design features 

(natural ventilation, slab heating/cooling, double façade, etc.) 
• Renewable energy systems 
• Cogeneration, fuel cells 
• Anything that requires dynamic simulation! 

 
 
Trnsys3d Plug-in 
The new building model contains 3D geometric surface information that is required for the 
new detailed radiation calculations. To easily input the geometric information into the building 
model, a plug-in called TRNSYS3d for Goggle SketchUp™ has been developed. The 
Trnsys3d plug-in is based on the open source program OpenStudio™  
(http://sourceforge.net/projects/openstudio). Therefore, it can’t be included into the TRNSYS 
package but is available for free download under GNU-GPL.  

Note that the plug-in is not a full-featured interface. It will not help you create non-geometry 
data, such as materials, constructions, controls, internal heat gains, HVAC equipment and 
systems, etc.. 

To use the plug-in as intended, you must have the energy model in mind (NOT the 
architectural model) from the beginning as you create your SketchUp model.  This means 
you should have your thermal zones defined before you start.  The following section 
discusses the differences between SketchUp Zones and Trnsys3d Zones. 
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Zoning Differences  

SketchUp Zones 

 
In SketchUp, the interior walls make up the zones. For example, in the building pictured 
above, there are no interior walls so it is modeled as one large rectangular zone.  Note that 
the smaller cube represents an exterior shade and is not a zone. 

Trnsys3d Zones (=AIRNODES)  

 
Trnsys3d zones are different from SketchUp zones, particularly because Trnsys3d zones are 
used to simulate the dynamic flow of energy. An energy model of a building should typically 
be separated into perimeter and core zones. This is important to separate the effects of 
infiltration from the perimeter and core, and to correctly account for solar gains into the 
building. In this tutorial, the example building is divided into two zones: the first floor with a 
shade (see the purple box), and the second floor, without shading.  It is also important to 
note that, unlike SketchUp zones which can be any shape imaginable, Trnsys3d thermal 
ones must be convex, meaning that every surface in the zone should be in the line of sight 
ith all other surfaces of the zone.  

z
w

 
   

convex concaveconvex concave
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Creating a Simple Energy Model  

Download and Launch the Software  

• Download and install Google SketchUp 7 from http://sketchup.google.com/. 

• Download and install Trnsys3d 

http://www.trnsys.de/docs/userservice/userservice_updates_de.htm 

• Start Google Sketchup. You will be prompted to choose a template.  

 
• Choose the ‘Engineering – Meters’ template and click ‘Start using SketchUp’.  

• Delete the drawing of the person standing at the axis origin by clicking on it and 
pressing ‘Delete’  
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Create a Trnsys3d Zone  

Create a new Trnsys3d zone by choosing Plugins ‐> Trnsys3d ‐> New Zone Tool  from 
the main menu. A small, blue cross‐hair will appear at the tip of the cursor arrow. Hover over 
the axis origin until a small yellow dot appears and click. This will place a blue box on the 
screen, which represents the Trnsys3d zone. If the blue box is not visible, try changing the 
view to fit the object by going to Camera ‐> Zoom Extents from the main SketchUp menu. 
Now you can zoom in and out with the mouse wheel to fit the object in the window as 
desired.  

 EAST 

SKY 

NORTH 

 
Note that by clicking on the screen outside of the blue box, the 
object will disappear from view. This is normal. Turn on hidden 
geometry (Go to View ‐> Hidden Geometry from the main menu) 

nd a small gray cross‐hair will be visible at the opposite corner 
f the box.  

a
o

 

 
 
This cross hair allows the user to find the Trnsys3d zone more easily. Note that if you click 
on the gray cross‐hair, the Trnsys3d zone is outlined in blue again.  
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Trnsys3d Zone Details  

Double click on the small cross‐hair, which is now visible with hidden geometry turned on. 
The blue outline of the Trnsys3d zone should be replaced with a slightly larger box with a 
broken, black outline. This ‘activates’ the Trnsys3d zone. Note that in order to modify the 

rnsys3d geometry the Trnsys3d zone MUST be ‘activated’ (outlined with the broken black 
ine). Alternative to clicking on the crosshair, you can double click inside the blue box. 
T
l

 

 
 
 
 

 

! 
This is what separates the Trnsys3d geometry from SketchUp 
geometry. Any object drawn in a ‘unactivated’ Trnsys3d zone is 
only SketchUp geometry and will not be written out to the 
Trnsys3d IDF file. It is VERY important to make sure the zone is 
activated before you start creating geometry. 
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Modifying Geometry within the Trnsys3d Zone  
Make sure that the Trnsys3d zone is still ‘active’ (outlined with the broken black line). Then 
create the floor for the model by going to Draw ‐> Rectangle  from the main menu. Start 
the rectangle at the axis origin by clicking on the origin. Next designate the size of the 
rectangle by typing ’12, 4’ and pressing enter (you can see the numbers being input in the 
lower right hand corner of the screen, the comma between the numbers is operating system 
language dependent and can also be ;,.). This will create a 12m by 4m floor.  

 

! 
Note the gray color of the floor. This color is automatically 
generated by Trnsys3d and designates this surface as a floor in 
Trnsys3d. Similarly, the walls and roof will be colored accordingly, 
in the next few steps. 

 

Next ‘pull’ the rectangle up to create a rectangular prism. Make sure that the Trnsys3d zone 
is still ‘active’ (outlined with the broken black line). Choose Tools ‐> Push/Pull from the main 
menu. Hover over the rectangle until small blue dots appear on the floor surface and click 
ONCE with the mouse. The tool will ‘grab’ the rectangle surface. Move the mouse up and 
down to see how the tool works. Move the mouse slightly up (so that the rectangle is 
projecting towards the top of the screen), type ‘4’, and press enter. This will ‘pull’ the 
rectangle up to create a 4m tall prism.  

     - 8 - 



Trnsys3d Tutorial  

! 
Saving the IDF File  
It is crucial to save the IDF file early and often. The IDF file is 
separate from the SketchUp file and saving the SketchUp file will 
not preserve the IDF information. To save the IDF file, choose 
Plugins ‐> Trnsys3d ‐> Save from the main menu . If it is the 
first time you are saving the file a dialog box will prompt you for a 
location and name. Call the file ‘tutorial1.idf’. Again, it is very 
important to save the IDF file early and often.  

 
Creating Fenestration Objects  
Trnsys3d can also be used to generate fenestration objects. Make sure that your Trnsys3d 
zone is still ‘active’ (outlined with the broken black line).  Use the tape measure tool to create 
a 1m offset guides from the corner of the wall.  Select Tools -> Tape Measure  and click 
once on the lower right hand corner.  Hover to a point above the corner, type in ‘1’ and press 
enter.  A small black crosshair will appear.  Using the tape measure tool again, click once on 
the new crosshair and hover to a point left of it, type in ‘1’ and press enter.  A dotted vertical 
guide and another crosshair will now appear on the wall surface. 

 
 
Now, select Draw -> Rectangle and click once on the crosshair located on the wall surface.  
Type in ‘6,2’ and press enter.  Note that as long as the rectangle is completely contained 
within the wall surface, Trnsys3d will recognize it as a window and automatically color it a 
transparent blue. A skylight is created the same way as a window, but the rectangle is drawn 
on a roof instead of a wall. The guide lines can be removed by going to Edit ‐> Delete 
Guides. This will also remove the hidden geometry. 
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Create Shading Objects  
Trnsys3d can be used to create shading objects, including overhangs and detached shading 
objects to represent other buildings. Select Plugins ‐> Trnsys3d ‐> New Shading Group Tool 

, which is very similar to the new zone tool. For this example, place the new shading group 
at the axis origin. Just like the new zone tool, in order to edit the shading group geometry you 
must make the group ‘active’. To do this, double click on the small gray cross‐hair that was 
reated when you placed the new shading group. When the shading group is ‘active’ you 
hould see the rest of the model become lighter.  

c
s

 
 

 
 

Use the rectangle tool to create the footprint of a detached shading object.  Click the origin 
once and move the mouse so that the footprint is previewed in the correct quadrant.  Type in 
‘4,4’, which will create a floor surface of 4m by 4m.  Notice that the gray dotted box extends 
itself to include the floor surface.   

 

 
 

Similar to creating a new zone, use the Push/Pull tool  to ‘pull’ the shading surface up to 
m.   4
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Using the Outliner Window  
We will now use the outliner window to review the zones that we have created. To access 
the outliner window from the main menu choose Window ‐> Outliner : 

 
You can use the outliner window to select the Trnsys3d objects by clicking on them. Double 
clicking on an object in the outliner window will ‘activate’ the object. You should have one 
Trnsys3d shading group and one Trnsys3d zone with a random six‐digit alphanumeric name. 
If you have any additional objects placed on accident select them in the outliner window and 
delete them.  

Using the Object Info Tool  

Trnsys3d also has the ability to modify the Trnsys3d object information. Choose Plugins ‐> 
Trnsys3d ‐> Object Info . The class type will change as objects are selected on the screen. 
If nothing is selected, the class type is ‘Building’. Change the name of the building to 
‘TRNSYS17’ 
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Click on the zone in the main SketchUp drawing area and you will see the class type change 
to ‘Zone’ in the object info window. Change the Zone name from the default six digit 
alphanumeric zone name to ‘First_Floor’ (!!!NOTE: No Spaces!!!). 

 
 

Open the outliner window again; notice that the Trnsys3d zone name has changed.  

 
 

! 
With the object info window still open double click on ‘First Floor’ 
in the SketchUp model to ‘activate’ the zone. Notice how the 
object info changes as you select a wall, roof, or window (note 
characteristics like surface name, type, construction, zone, 
outside boundary conditions, and the ground view factor). You 
can change the name, the surface, the surface type, and the 
construction for each surface. ! Note: Leave the surface name as 
it is, this will be automatically changed later on!. Toggle between 
surfaces by clicking on them on the main SketchUp window. 
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Adding a Second Zone to the Simple Model 

Create the second floor of the example model by creating a new Trnsys3d zone and 
repeating the previous steps, but ‘pull’ this floor to 5m instead of 4m.  To create a sloped 
roof, portions of the rectangular prism will be ‘sliced’ off.  Using the tape measure tool, place 
a crosshair guide 1m below the upper corner, as shown below.  Then select Draw -> Line  
and draw a line from the crosshair to the midpoint of the top edge. (The midpoint shows up in 
blue when you hover over it.) Draw another line connecting the midpoint to the edge opposite 
of the one with the crosshair, outlining the shape of the sloped roof. 

 
Select Tools -> Push/Pull, hover over a triangle until the blue dots appear and click once 
inside the triangle.  Move the mouse towards the other end of the prism until the cut follows 
through the entire length of the prism and click to complete the ‘slicing’ (the cursor will snap 
to a triangle at the other end.)  Repeat for the other triangle.  

         
Note that the sloped roof you just created is now the same color as the walls.  To re-assign 
the surface type in Trnsys3d, right-click on the surface make the selections as shown below 
o finally choose ‘Roof’ for each sloped surface.  Repeat previous steps to rename this zone 
s “Second Floor” 

t
a
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Finally, the interzonal adjacencies must be considered.  The mating surfaces between the 
First Floor and Second Floor must be linked together.  First, open Window -> Outliner, and 
right click on the Second Floor to ‘Hide’ it.  If View -> Hidden Geometry is checked, then the 
second floor will appear hatched.  You must uncheck it, to hide it entirely. 

 
Next, double click the First Floor zone to ‘activate’ it.  Right Click on the roof of the first zone 
and select Trnsys3d -> Object Info. Change the Type to “Ceiling” and construction to 
“ADJ_CEILING”. The outside boundary condition should be “Zone” and the outside boundary 
object is “Second Floor.” 

 
 

 

Right click on the Second Floor in the Outliner to unhide it.  Repeat the same steps above to 
hide the First Floor and reassign the floor of the Second Floor correctly. See the Object Info 
entries below.  Note that although the type of the Second floor is ‘Floor’, the construction 
must match the First Floor (ADJ_Ceiling).  This is critical for adjacency recognition, when 
importing into TRNBUILD.  
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VirtualSurface Definition 
Note that thermal stratification is normally modelled with a stack of 
several zones.  To model this, example an atrium, assign the 
construction as ‘VirtualSurface’.  When it gets imported into the 
TRNSYS TRNBUILD, the VirtualSurface will automatically be deleted 
and reflect an accurate radiative model. 

! 

Alpha Feature: method for matching surfaces 
An experimental method for matching surfaces is currently in alpha 
testing and may be accessed through the SketchUp ruby console 
through the following steps: 

1. Open the SketchUp Ruby consoler through ‘Window->Ruby  
      Console’ 

2.  Type ‘Trnsys3d::match_surfaces’ to match walls, roofs, and floors 

3.  Wait, this is currently a slow process for large models 

 

Note that this method requires several key assumptions.   

First, in order to match two surfaces the methods requires that they 
both have same number of vertices and that the vertices exactly line 
up.  This can most easily be accomplished using the snap 
functionality of the SketchUp drawing tool.   

Secondly, construction names of the matched surfaces will be 
changed to (for each corresponding surface or sub surface type):  
"ADJ_CEILING" and "ADJ_WALL" if construction objects of those 
names appear in the current idf file.  If construction objects with the 
assumed names are not found, then the construction of the matched 
surface will not be changed. 
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Using the 3D-Building WIZARD in the TRNSYS Simulation Studio 

Importing the *.IDF file 
For the first run of a simulation, the TRNSYS17 Simulation Studio offers the opportunity to 
automatically set up a simulation by importing the *.idf file with the 3D-Building Wizard. After 
opening the Simulation Studio you can select ‘New Project’ in the menu and the 3D-Building 
Project Wizard can be chosen. The Wizard prompts you for the *.idf file that you previously 
generated using the Trnsys3d in Sketchup. Select the *.idf file and a simulation with the most 
important links for a first run are automatically generated. Check the assigned weather data 
and run the model.  After importing the model, a new *.idf file will be generated which 
includes, the original name, an underscore and ‘B17’, for example ‘Building_B17.idf’. This file 
is including the surfaceID’s as shown in the building description file.  

 
A great advantage of the 3D-Building Wizard is that all orientations of the Building are linked 
automatically. This reduces errors and time used to link this information manually. 
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Viewing Results 
Trnsys3d can be used to view Trnsys3d results. But first, the Trnsys3d requires results to be 
printed from the Trnsys3d Printer (Type 125), which is retrieved from the Direct Access 
Toolbar in the TRNSYS Simulation Studio.   

 
The Trnsys3d Printer will generate *.eso files that can be read by the Trnsys3d plugin to 
visualize results. The Trnsys3d printer can be configured in two different ways. 

1) The SurfacesID’s (corresponding to the ID’s in TRNBUILD) are required as initial values.  

   
2) The ZONE Names (corresponding to the names in TRNBUILD) are required as initial 
value. Initial value has to be defined as STRING. NO SPACES! 

      
The information from the surfaces and zones can now be linked to Type125.  After linking the 
surfaces and zones, the ***_B17.idf model can be reloaded into Trnsys3d. First, go to the 
main SketchUp menu and chose Plugins ‐> Trnsys3d ‐> Renderings ‐> Settings . This will 
open the rendering settings dialog box.  
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Set the data path by browsing to the directory where you saved your IDF file. There should 
now be an ESO file generated by the Simulation Studio during the simulation. Choose the 
ESO file for the data path. The run period will automatically be filled once the ESO file is 
selected. Set the rest of the Rendering settings as shown above and click ‘OK’. The dialog 
box will close and nothing will appear to change. We now need to set Trnsys3d to render by 
data value instead of by surface class. To do this go to the main SketchUp menu and chose 
Plugins ‐> Trnsys3d ‐> Renderings ‐> By Data Value . 

If any portion of model appears white, it indicates that no data results are available from the 
TRNSYS simulation for the selected date for that zone. The model should be colored based 
on the zone air temperature, as shown below. 

 
Try matching the simulation run period in Trnsys3d with the Trnsys Simulation Studio results 
by setting it to the first week of January. In the SketchUp main menu, choose Plugins ‐> 
Trnsys3d ‐> Animation ‐> Settings. This will open the Animation Settings dialog box. 
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Check the ‘Match simulation run period’ and the ‘Repeat when finished’ checkboxes as 
shown above and hit ‘OK’. Lastly we need to reset the time to the beginning of the run 
period. In the SketchUp main menu, chose Plugins ‐> Trnsys3d ‐> Animation ‐> Reverse to 
Marker. Make sure that the bottom left corner of the screen indicates January 01. If it says 
January 08, choose Plugins ‐> Trnsys3d ‐> Animation ‐> Reverse to Marker again. Now the 
bottom left corner of the screen should say January 01. Also, turn on shadows to see the 
position of the sun by going to View ‐> Shadows from the main SketchUp Window.  

 
Now that we have reset the time and have shadows on, we are finally ready to view the 
animation. To begin the animations go to the SketchUp main menu and chose Plugins ‐> 
Trnsys3d ‐> Animation ‐> Play. At the bottom left of the screen you will see the time and date 
as the animation progresses. Notice that the zones are all slightly different colors, meaning 
that their temperature is different because of their construction, occupation,…..  

While the simulation is running we can view the temperature scale by going to the main 
SketchUp menu and chose Plugins ‐> Trnsys3d ‐> Renderings ‐> Color Scale . Stop the 
animation the same way you started it, by going to the SketchUp main menu and chose 
Plugins ‐> Trnsys3d ‐> Animation ‐> Play . Once the date passes the end of our run period 
the model will turn white because there is no data for it to display. The animation can begin 
from the beginning by first halting playback by going to the SketchUp main menu and choose 
Plugins ‐> Trnsys3d ‐> Animation ‐> Play and then resetting the time by going to the 
SketchUp main menu and chose Plugins ‐> Trnsys3d ‐> Animation ‐> Reverse to Marker. 
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Using Trnsys3d for TRNSYS17 - Tips & Tricks 

General 

• Read the SketchUp documentation. 

• Check that unit settings are set to “High” accuracy  

• You may encounter difficulties using directories with “ä”, “ö”, “ü”, blanks etc. 

• To position vertices with precision or create surfaces with exact dimensions, use the 
Value Control Box (VCB) in the lower right corner or use construction lines.   

• To draw quickly and accurately, use SketchUp’s snapping capabilities.  For example, 
to match the x-, y-, or z-position of the endpoint of a line, hover the cursor over the 
endpoint until the tooltip appears. Click ONCE.  As you move the mouse, SketchUp 
will let you know when you are parallel to the reference line.  To lock an snapping 
functions along an axis, hold down the shift key while you draw, and the line will 
appear bold and in the same color as the parallel axis. 

 
Zones 

• In TRNbuild, a zone can include multiple air-nodes.  However, it is recommended to 
draw each air-node as one zone in Trnsys3d. For example, in an atrium, thermal 
stratification is often represented with multiple air-nodes.  In Trnsys3d, each air-node 
should be defined by a separate zone and the construction of the adjacent ‘surfaces’ 
between the zones should be assigned to ‘VirtualSurface’. These surfaces are then 
deleted automatically, when importing into TRNbuild, allowing for an accurate model 
of the radiative zone. 

o Within TRNbuild you can move air nodes from one zone into another 
(including the geometric information).  This way you can create radiative 
zones with multiple air nodes. 

  
o Radiative zones must be enclosed with surfaces for the correct calculation of 

the volume. 
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• To use the detailed radiation mode, the radiative zones must be convex polyhedrons. 
 

convex concaveconvex concave  
• It is preferable to place the zone origin close to the origin of the world coordinate 

system (WCS). However, if the WCS is far away, you may not see the zone’s 
surfaces when the zone is selected. A possible solution is to edit the zone origin in 
the *.IDF file manually.  

• Give zones “meaningful” names. No blanks are allowed!! 

• Use the Outliner window (Window/Outliner) to view a list of all of your zone groups 
and shading groups. Groups can be selected by clicking items in the outline. Groups 
can be opened for editing by double-clicking items in the outline. 

 
• Use the command View/Component Edit/Hide Rest Of Model to hide all other groups 

(and the rest of the model) when you are editing a group.  When used with the 
Outliner, this command helps you get to zones that are buried in the core of a 
building. 

• When drawing two or more zones with interzonal adjacencies, it is easier to draw the 
zones completely apart from each other, set the interzonal connections with the 
Object Info window, and then move them into final position using the Move tool. 
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Surfaces 

• In Trnsys3d, all building surfaces (walls, floors, etc.) are represented in 3-D 
coordinates as infinitesimally thin.  Zone volume and surface area, which are 
automatically calculated entities, are derived from those 3-D coordinates.  However, 
you may modify the volume within TRNbuild. 

• The construction that you select for each surface determines the thickness for the 
purposes of the heat transfer calculation, but it does not affect any geometric 
considerations. 

• Typically, the building surfaces are measured from the outside edge of exterior walls, 
and the centerline for adjacent walls.  At the building corners, measuring from the 
outside edge will overestimate the total mass of the walls, while measuring from the 
inside edge will underestimate it. It is easier to measure the outside edge from the 
blueprints, but measuring from the centerline is the more accurate approach.  If the 
walls are especially thick, consider measuring from the centerline of the exterior 
walls.   

• The y-Axis is pointing north. There is no way to change this. 

• To add surfaces to a zone, the zone must be ‘activated’ by double clicking the blue 
outline.  An activated zone will be outlined in a grey dotted line. 

• Surfaces have to be drawn with an outward-pointing normal vector! Occasionally 
when you draw a surface, SketchUp will guess the wrong side to face out. You can 
tell because the side facing inside is a lighter color than the side facing outside. To 
correct this, use the SketchUp command Edit/Face/Reverse Faces. 

• Note that even if you rename your surfaces, they will be replaced with the surface IDs 
that are generated automatically when importing into TRNBuild. 

• Check and set the correct “Type” of all adjacent surfaces (Wall, Floor, Roof, Ceiling). 

• Select a “construction” for each surface. Otherwise the surface cannot be imported 
into TRNBuild correctly. The constructions can be modified within TRNBuild later. 

• This shows the translation of  “Outside Boundary Conditions” into TRNBuild syntax: 

o Outdoors    =>  EXTERNAL 
o Ground    =>  BOUNDARY = INPUT 1*TGROUND 
o Zone      => ADJACENT = zonename 
o Other Side Coefficients => BOUNDARY  

• Adjacent surfaces have to exist twice (once for each radiative zone), but with different 
normals.  Despite ‘Type’ differences (floor/ceiling, wall/wall, etc), adjacent surfaces 
must have the same construction for proper syncing within TRNBuild.  

• Active slab surfaces should be divided in Trnsys3d (3 partitions for the active slab 
system are sufficient). To create divisions, simply draw a line. 

 
• Check for holes in surfaces.  Holes will generate errors when importing into TRNBuild  

• Windows are linked to its base surface and should not have more than four vertices. 

• It is better to model the window frame as a Wall and set FFRAME = 0. 
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• If you copy and paste surfaces make sure that the destination zone is active. You can 
copy surfaces from one Trnsys3d file into another, but sub-surfaces (windows) will 
not be recognized.  Review Trnsys3d surface entities by checking “Object info” 

Shading groups 

• Draw shading groups after you have finished your building 

Troubleshooting 

• Use “Wireframe View” for checking if adjacent surfaces are mated. 

• Check the number of surfaces and sub-surfaces in each zone.  

• Always OPEN and SAVE the file within the Plug-in. 

• Before closing the IDF file in Trnsys3d, save it and open it in another Sketchup file to 
check that everything works accordingly. 

• Before closing the IDF file in Trnsys3d, translate the IDF file into B17 and check if 
everything is translated and make sense. 
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Importing geometry created in AutoCAD into Sketchup 

Creating the geometry in AutoCAD 
• Create one big volume, cut off surplus volume with volume cut function (e.g. atrium or 

undercutting volumes). Make that all edges meet, creating a sealed volume! 
• Divide this volume into zones/airnodes by using the cut function). In this way, groups are 

created automatically after exporting. 
• When drawing windows, keep a small distance from the edges of walls and stay within wall 

boundaries.  A common mistake is applying a scaling factor to the wall to create the window. 
• For each air-node, use two groups: one group for walls and one group for windows. 
• Move the model to the xyz origin 0,0,0.  This is critical for SketchUp to create the *.idf files 

properly.  Also, it would be easy to add elements later.) 
• Save this file as *.dwg  

Importing the *.DWG model into Sketchup  
• Open SketchUp 
• Adjust the units parameters as shown:  

 
• Import the DWG file  

 
• Press the “options” button and adjust the settings like this: 

 
• Sign the “preserve drawing origin” and click OK 
• Save this file in Project folder as *.skp 
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Copying geometry from an imported *.DWG into the Open Studio  

Preparing the *.skp model for use in Trnsys3d and TRNSYS17 
• Open the “Show outliner window” of Open Studio plugin to see the imported data. You will find 

the zone(s) as grouped objects. 

  
 
• Copy the wall surfaces of a zone by highlighting one group and right-click/copying it. 
• Open another Sketchup window to use the Trnsys3d plugin.(This minimizes error messages 

and provides a better overview what’s already copied into zones) 
• Create a new Trnsys3d zone and assign a short name (no blanks).  

 
• Activate the zone by double clicking it in the outliner (a dotted grey line will outline the zone) 
• Select Edit-> Paste in place and the wall elements are now walls of the zone. 
• Explode the copied zone by pressing right mouse button on the group and selecting “explode”. 

The color of surfaces will now change (grey: floor, beige: wall, dark red: ceiling). 

       right mouse click 
• Switch to the other Sketchup with your imported *.dwg file and “Copy” the window surfaces of 

the zone you just copied.  
• Switch to the Open Studio Sketchup window and check that the zone is still active (grey dotted 

outline). Then, select Edit->Paste in place, and the window elements are now windows related 
to the base surface of the zone. The windows should now be cut out of the wall. 

• Save in Trnsys3d by choosing Plugins ‐> Trnsys3d ‐> Save from the main menu. 
• Repeat this procedure for every zone. 
• When all zones are finished, adjust the boundaries and the adjacencies in each Trnsys3d 

zone, use “Object Info” to assign the Construction, Zone, Outside Boundary Condition and 
Outside Boundary object.  Adjust only the walls, ceilings, roofs, and floors. The integrated 
windows will adjust themselves. 

 
 

• Save the Trnsys3d file one final time and *.idf  file is now readable for TRNSYS 17 
• Save Sketchup 
• Reimport this *.idf file into a new SketchUp file within Trnsys3d mode and all model elements 

should appear correctly. 




